如何编译及安装 Canvas Android Apps

发布于: 27 September, 2022
分享:

配置 flutter 开发环境

下载 flutter

flutter 版本有讲究,目前测试版本为 2.5.3,如使用最新版本无法正常编译。

https://docs.flutter.dev/get-started/install

根据自己的系统选择对应的配置教程。如果使用 Git 获取 Flutter,可通过 git checkout tags/2.5.3 切换至 2.5.3 版本

 

检查 flutter 环境是否正确:

$ flutter doctor

 

接受 Android 使用条款:

$ flutter doctor --android-licenses

一路按 "y" 接受即可。

再次运行 flutter doctor,检查开发环境,如一切正常,结果如下图所示:

 

C:\Development\canvas-android> cd libs\flutter_student_embed
C:\Development\canvas-android\libs\flutter_student_embed> flutter pub get

安装 JDK

Kotlin 需要 JDK 编译环境,以 macOS 为例,下载地址如下:(需要 Oracle 账户登录)

macOS: https://www.oracle.com/java/technologies/downloads/#java8-mac

安装 Android Studio

安装向导默认安装结束后,首先检查 SDK 目录路径,通常 macOS 环境下路径为:/Users/xxxxxx/Library/Android/sdk

0 留言

留言

您的留言将被人工审核,请勿发表色情、反动言论。

您可能感兴趣

Canvas LTI 外部工具详解

Canvas LTI 集成是将第三方学习工具嵌入 Canvas 中,实现无缝整合和交互,提供更丰富的学习体验和功能扩展...

拓朗调研报告:微软凭借 OpenAI 夺回手机市场

微软入局 OpenAI 董事会已成定局,产品架构重大调整或已启动,微软是否收复智能手机这块失地,并为注入最强...

Canvas LTI XML 配置范例

Canvas 支持 LTI 标准协议,用于在 Canvas 学习管理系统(LMS)和外部教育工具或应用程序之间进行集成。这...

查重利器!应对 Chat GPT! Canvas 学习系统配置 Turnitin 插件

在Canvas LMS中整合Turnitin LTI应用程序,可以轻松检测学生作业中的抄袭,帮助教师维护学术诚信,确保学生...